black images G7X Mark II

Discussion in 'Canon G1X / G7X Forum' started by GianniB, Mar 1, 2017.

  1. GianniB

    GianniB New to SC

    4
    Mar 1, 2017
    gianni baroni
    Canon. Randomly the screen of my new G7X mark II gets black. Only icons and values are shown. If I shoot a picture it is completely black. Do know what to do. I bought it just one day before departure for vacation and now I'm in Thailand and my camera works randomly. I tried to reset to factory settings using the menu tab nb 4, but it doesn't work... any idea?
     
    Last edited: Mar 2, 2017
  2. bluzcity

    bluzcity SC Veteran Subscribing Member

    379
    Jul 30, 2013
    Memphis, TN
    Brent
    Is it a display issue or is the screen going blank? If you take a picture and push the little arrow button (bottom right of camera, just to the left of the menu button) do you see a picture? The way it shows the photo information on your screen shot it seems like the display is not toggled to the position that shows the image on screen. Is there a camera store you can wander into and ask someone? Hope you get this fixed.
     
  3. Luke

    Luke Super Moderator Subscribing Member

    Nov 11, 2011
    Milwaukee, WI USA
    Luke
    when you say "randomly", do you mean truly at random, or do any certain specific image files display as black every time while other images always display fine?

    If you remove the lens cap and take 5 photos, can you play back those 5 images?
     
  4. GianniB

    GianniB New to SC

    4
    Mar 1, 2017
    gianni baroni
    View attachment 124060
    If I take a picture (even if the screen is black), then i get a black picture. To me there is a connection problem between the sensor ad the
    how can I remove the lens cap?
     
  5. Luke

    Luke Super Moderator Subscribing Member

    Nov 11, 2011
    Milwaukee, WI USA
    Luke
    I guess a better question is "when is the screen NOT black"?
     
  6. bluzcity

    bluzcity SC Veteran Subscribing Member

    379
    Jul 30, 2013
    Memphis, TN
    Brent
    I did a Google search and it turned up several cases of the automatic lens cap on the GX7 getting stuck. I think Luke's question is spot on.
     
  7. Luke

    Luke Super Moderator Subscribing Member

    Nov 11, 2011
    Milwaukee, WI USA
    Luke
    so sometimes it opens all the way and takes a photo and sometimes it gets stuck and you get a black frame....that makes sense. Should be easy enough to check. Power the camera on and make sure the lens cover opens all the way. Take a photo, then attempt playback.
     
  8. GianniB

    GianniB New to SC

    4
    Mar 1, 2017
    gianni baroni
    1) It is more t'ha 24 hours the problem in permanent and no more randomly
    2) lens cover works perfectly
     
  9. Luke

    Luke Super Moderator Subscribing Member

    Nov 11, 2011
    Milwaukee, WI USA
    Luke
    hopefully you have the receipt and it's still under warranty. I'm out of ideas.
     
  10. GianniB

    GianniB New to SC

    4
    Mar 1, 2017
    gianni baroni
    I bought it 10 days ago via Amazon. They'll replace it with a new one rapidly... it's the beauty of Amazon!
    Thanks to Luke and Bluzcity for the support
     
    • Like Like x 1