1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

ISO stuck on iso320 cannot change any lower

Discussion in 'Ricoh GR (APS-C) Forum' started by biglouis, Mar 15, 2014.

  1. biglouis

    biglouis SC Veteran

    401
    Aug 4, 2013
    This has happened to me regularly.

    I use the camera mostly with the metering set to TAV but occasionally I use AV.

    I cannot set my iso lower than iso320. Even if I select, for example, iso100 and press the OK button the iso does not change. It will change to above iso320.

    Is there another setting somewhere in the camera which is conflicting with this? I think the last time this happened I was so frustrated I reset the camera to default settings as the only way to get around this problem.

    I wonder if it is a bug in the firmware or else I have just set something else in the camera which is causing the conflict.

    Any ideas?

    Louis
     
  2. Psus4

    Psus4 SC Rookie

    11
    May 12, 2013
    Stockholm
    Patrik
    Check if you have Dynamic Range Compensation on. If you do, set it to off. That did the trick for me, at least.
     
  3. Luke

    Luke Super Moderator

    Nov 11, 2011
    Milwaukee, WI USA
    Luke
    Louis, It's been awhile since I used a Pentax made camera like your GR, but I think in TAV mode you set the aperture and shutter speed and are handing over the ISO control to the camera to get the correct exposure.
     
  4. biglouis

    biglouis SC Veteran

    401
    Aug 4, 2013
    Thanks, that did the trick.

    I should have made it clear, this is happening in AV mode - I know that in TAV mode the iso is selected to match the speed/aperture.

    Thanks again.

    Louis
     
    • Like Like x 1