My RX1 just arrived / first impressions / questions / button settings / AF-info

Discussion in 'Sony RX1 Forum' started by Neoviny, Mar 2, 2014.

  1. Neoviny

    Neoviny New to SC

    8
    Feb 23, 2014
    Well, after reading a lot of threads in this rx1 forum it's time to share my experiences with my "new" RX1 :rolleyes: I was able to order it directly from the sony outlet store (germany) for an insane and awesome price - this means that this RX1 has been in use and was returned to sony. The camera was fully inspected by the sony service and the cam comes with the same warranty like a new one. That said, I wasn't able to find any scratches or any kind of signs that this cam has been used a lot - all dials are superb and the aperture-/focus-ring are top notch.

    After my first steps with this cam I thought that maybe the lcd-display has some sort of malfunction because in neon-light (at the office) there has been a color-fringe above and below of the focus area - looked a bit weird but it didn't turned out to be visibale on the pictures I shot. In other light conditions everything seems to be right, instead of some sort of flickering in low light now and then. But nothing serious and I'm not concerned about it (maybe it's normal? at least with the RX100 I never had this flickering).
    Even if these are little downsides of this "used" cam, I'm sure I absolutely can live with that due to the fact that I was able to save a loooot of money :biggrin:

    But there seems to be one thing, that I didn't expected and I don't know if this is normal or an issue with my cam: when I shot very fine detailed things at f2 (a camera bag, a wall with very tiny structures) it seems that there is a color fringe in the very small focus area - it looks like there is some kind of red toned part on the downside and a bit of green toned directly above - when zooming into the photo the color patterns are not visible. Is it possible that these are moirés? I have to admit I thought I was able to force the camera to produce moiré while shoting in a wool-market with VERY tiny felt-patterns: on the lcd I could see a lot of moiré flickering all the time, but on the photo it wasn't visibal anymore.

    What I noticed also is that the camera produces moiré in video mode. Well, I expected this to be not a problem for the rx1, but more for the rx1r.

    Everything else is just perfect about this cam and I love the output very much. After just 2 days I'm very sure that it was (for me) the right decission to sell my dslr equipment and heading for the rx1 :rolleyes:

    Because I was very familiar with the handling of my rx100 the process of custimizing my rx1 was pretty easy and didn't take a lot of time (yeahaw). And I really LOVE the way I can customize this cam! My settings are these:

    c-button: zoom/teleconverter
    wheel-left: white-balance selection
    wheel-right: ISO-selection
    wheel-down: metering-selection

    and (and it's a very very very BIG AND):
    the AEL-button: AF/MF-switch

    so, why is this such a big and for me??? well - here we come the thread's title "AF-Info": I never heard something about this in the last 2 month in any of all the reviews or threads I read - so the point is: because I was very familiar with the handling of my rx100 I allways used it in direct-manual focus because it saves battery-life and it gave me the option to re-adjust the focus instantly when necessary. The rx100 was perfect with this setting and so I instantly decided to set the AF-switch of the RX1 to DMF.... but: the RX1's AF is stumbling over this setting.... when I'm in DMF-Mode and in low-light conditions (well, not even only there) the AF hunts very often and took at least (!) one second to focus. And I realised that when it's set to AF the focus is A LOT quicker !!! To be honest: I knew from the beginning that the RX1's AF wasn't speedy at all, but the AF-speed in DMF was really quite frustrating to me and I thought that maybe the camera has a malfunction. But with the AEL-button set to AF-MF-switch I'm in full control of both: a faster AF and the option to switch to MF to use the focus-peaking function when necessary and with just one stroke on a button. I love it that way and I'm very very happy about this option :biggrin:

    Even that I would love to have at least one more customizable button, I'm very excited about the ease of use of this little beauty!!!

    I'm looking forward to share some pictures as well... :wink:

    Neoviny
     
  2. rbelyell

    rbelyell SC Top Veteran

    820
    May 14, 2013
    NY Mtns
    i have it set up that way also, as it is how i always shot my x100, seperating focus from metering. i have no focus hunting issues at all. i do however get loads of purple fringing, especially in three braches against a backlit sky. very disappointing in this quality of camera. besides that and the stupid auto iso implementation, everything else is great.
     
  3. oliveview

    oliveview SC Regular

    45
    Dec 9, 2013
    I shoot in RAW, and have every single internal adjustment turned "OFF" on my RX1. In my shooting so far, I've really abused its dynamic range, from shooting right into the sun, to shooting extremely harsh contrast subjects. But the chromatic aberration is so mild compared, especially compared to my Nikon D300s with the 50mm 1.4 G lens.

    When I do see it, I can gobble it up and make it disappear quite beautifully with some slight CA adjustments in LR's "Color" mode within the "Lens Correction" tabs. I'm simply blown away with the quality this camera is delivering, especially now that I'm getting used to just what needs to be pushed and pulled in LR. It's making me more of a fearless photographer when I'm out, because it can help compensate for absolutely ridiculous shooting conditions. Again, my old Nikon would be delivering almost unusable files if I were to shoot it that way. Granted, that sensor in the Nikon is about six-years old.