N00b questions - RX1 shutter priority mode and autofocus

Discussion in 'Sony RX1 Forum' started by danedmunds, Dec 18, 2013.

  1. danedmunds

    danedmunds New to SC

    Dec 18, 2013
    Hello, this is my first post, after doing lots of procrastinating I decided I needed a decent camera to take pictures of my daughter and decided to get an RX1. Now I am complete noobie to photography, perhaps a rather extravagant purchase but I do not regret the decision at all. I am astounded by the quality of the pictures that even my meagre skill can pull from it - when I can figure out how to get it to do what I want :redface:

    Whilst I have got to grips with most of the shooting modes, the shutter priority mode seems to be doing something weird or I am doing something wrong. I tried searching the forum but couldn't find anyone else with this issue:
    Regardless of what shutter speed I select, the display will show the subject for a second or so and then go black and just generates blank pictures. All the other modes seem to work as intended and the sports scene selection mode works as well, just not shutter priority. Any ideas?

    Also I am confused about what autofocus options are available in each mode. It seems that in P/A/S/M modes I can select Center and Flexible spot but in Auto mode it only allows me to use Multi, is this right?
    Is the AF mode the same as DMF with the exception of manual focus adjustments or are the any other differences?
    It seems that when the autofocus is set to Center it locks on pretty much every time but with Multi it seems more inconsistent. If there is a way to turn on Center focus in the full Auto mode my wife will be considerably happier
  2. staticantics

    staticantics SC Regular

    Oct 15, 2013
    Central California
    Real Name:
    I suspect it has to do with the amount of available light. You lens aperture cannot open any wider to allow more light in, so if you set your shutter speed at 1/300s and the camera will automatically adjust aperture to balance your shutter speed selection. So the camera cannot get any wider than f2.0, limiting the total amount of available light to get to the sensor. So essentially, the shutter speed opens and closes too fast to allow light to expose the scene.

    Try upping your ISO, or setting your ISO to automatic and the problem will likely fix itself.
  3. ccrevasse

    ccrevasse SC Regular

    Nov 20, 2013
    Lookout Mountain, Tennessee
    Real Name:
    Chris Crevasse
    In Auto mode, only multi AF is available. You can select Center and Flexible Spot in Program mode, though, which is very similar to Auto. Af and DMF modes are the same except that DMF allows manual focus adjustment after autofocus is achieved.

    I don't know what's going on with your S mode, but it sounds to me like your camera is defective.
  4. danedmunds

    danedmunds New to SC

    Dec 18, 2013
    Thanks for the feedback.
    Staticantics - you were absolutely right, I underestimated how slow I needed the shutter speed in order to capture an image.

    ccrevasse - thanks for the clarification, I would like to use the P mode but our daughter moves too quickly! (not a bad thing in the grand scheme...)

    I did a bit more playing around last night and found that if I selected Scene/Sports and turn on face detection it was easy to get consistently sharp pictures of our daughter, no matter how much she moved around.