Problem with Panasonic 25mm f/1.4 (m4/3) and Olympus Cameras

Discussion in 'Micro Four Thirds Forum' started by soundimageplus, Aug 23, 2011.

  1. soundimageplus

    soundimageplus SC Top Veteran S.C. Charter Member

    578
    Jul 6, 2010
    Anyone using a Panasonic Leica 25mm f/1.4 (the new m4/3 one) with an Olympus Pen body?

    Mine arrived this morning and the aperture blades are constantly moving and "clicking" adjusting to the light, when the live view or EVF are on.

    Only way to stop it is to turn the AE lock on.

    I've used it on an E-PL1 and E-P3 and its the same on both. Everything is working fine apart from this, the pictures are perfectly exposed and very sharp.

    If you are using this combination with no problems then I know I have a faulty one.
     
  2. BruPri

    BruPri SC Top Veteran

    698
    May 11, 2011
    Seattle, Washington USA
    Real Name:
    Bruce J. Pritchard
    I have an E-P1 w/Oly 17mm and does the same thing, always has...
     
  3. soundimageplus

    soundimageplus SC Top Veteran S.C. Charter Member

    578
    Jul 6, 2010
    Its just so loud! People were turning round when I walked past them! I reckon you can hear it from about 30 feet away. Is that your experience?
     
  4. BruPri

    BruPri SC Top Veteran

    698
    May 11, 2011
    Seattle, Washington USA
    Real Name:
    Bruce J. Pritchard
    Geesh no, I have to really listen to hear the blades adjusting, but i am aware of it...sort of a low level clicking sound as it opens/closes when aiming the lens in different directions.
     
  5. Djarum

    Djarum SC All-Pro S.C. Charter Member Subscribing Member

    Jul 10, 2010
    Huntsville, AL
    Real Name:
    Jason
    My 17mm does this when it is really bright outside. I always thought that the aperature always stayed wide open during live view.
     
  6. soundimageplus

    soundimageplus SC Top Veteran S.C. Charter Member

    578
    Jul 6, 2010
    Video

    Someone just posted this video for me on mu-43.
    <iframe src="https://www.youtube.com/embed/EnEP41U1dgM" allowfullscreen="" frameborder="0" height="345" width="560"></iframe>

    This is exactly what I'm getting only its louder on the 25mm f/1.4. Bigger aperture blades I guess.

    I'm just about to start reviewing this lens and I thought I'd check this out before I start. It will certainly be a part of the review.

    Do Panasonic bodies have the same problem?
     
  7. soundimageplus

    soundimageplus SC Top Veteran S.C. Charter Member

    578
    Jul 6, 2010
    Just to put an end on this. A G3 doesn't present the same problem I've discovered. There is still the occasional click, but its much quieter and the Panasonic camera adjusts the aperture in one move rather than the step by step approach of Olympus.

    My local dealer let me try this out, having been somewhat intrigued when I showed him the phenonenom on the Olympus. I therefore bought the G3 and will sell my E-PL1 + 3 kit zooms to pay for it.