PS Elements 9 rumour

Discussion in 'Image Processing' started by Fuddlestack, Dec 8, 2010.

  1. Fuddlestack

    Fuddlestack SC Regular

    138
    Dec 1, 2010
    Alsace, France
    A couple of people on other lists have reported installation problems with PS/EL 9. I was thinking of getting it for my wife, but I don't want to spend the Christmas hols with my nose in a machine - that's what I do the rest of the year.

    Has anyone successfully installed this thing on a Vista system?
     
  2. Ghosthunter

    Ghosthunter boo!

    Sep 8, 2010
    London UK
    Andy
    I have it on a MAC and it installed perfectly BUT it is slower than Elements 6 that I used before. If you use RAW and don't need to upgrade the Camera Raw bit then I would stick with what you have. Elements 9 is very nice and quite a nice jump from 6 but I do find I'm doing the same stuff in 9 than I was in 6. I don't use the 'Organise' bit as I have Lightroom 3.3 for that but I'm still glad I made the switch.
     
    • Like Like x 1
  3. olli

    olli Super Moderator Emeritus

    Sep 28, 2010
    Metro Manila
    olli
    I downloaded the trial version onto my laptop which is running Vista. I haven't used it that much but so far I haven't had any problems.
     
  4. Wally Billingham

    Wally Billingham SC Regular

    106
    Nov 27, 2010
    Laurel, MD
    it works fine on my wife's PC with Vista home premium, no issues at all
     
  5. Fuddlestack

    Fuddlestack SC Regular

    138
    Dec 1, 2010
    Alsace, France
    Thanks for the input - it's nice to know.