1. Reminder: Please use our affiliate links for holiday shopping!

site slowness (your responses desired)

Discussion in 'Help and Feedback' started by Luke, Sep 4, 2013.

  1. Luke

    Luke Super Moderator

    Nov 11, 2011
    Milwaukee, WI USA
    Luke
    Hi All,
    I just got a message from a forum regular that he was having trouble getting the site to open on his Mac. He has cleared everything out and all other sites open quickly. My 2 windows machines are operating normally. Anyone else having issues or is this an isolated case?
    Thanks for checking in.
     
  2. Armanius

    Armanius Bring Jack back!

    Jan 11, 2011
    Houston, Texas
    Jack
    I've been having slowness issues as well in my MacBookAir.
     
  3. KillRamsey

    KillRamsey SC Hall of Famer

    Jun 20, 2012
    Cambridge, MA
    Kyle
    No issues on a pc
     
  4. Djarum

    Djarum SC All-Pro

    Jul 10, 2010
    Huntsville, AL
    Jason
    None here, running IE8 on XP SP3.
     
  5. pniev

    pniev Student for life

    Jun 10, 2013
    No issues here (mac, os x 10.8.4, firefox). Is the performance issue site specific?
     
  6. Lightmancer

    Lightmancer Super Moderator

    Aug 13, 2011
    Sunny Frimley
    Bill Palmer
    No issues on XP or Win7, Firefox up to date. No issues on Dolphin on Android, or on Tapatalk.

    Sent from another Galaxy
     
  7. pdh

    pdh SC Legend

    Jan 2, 2011
    Seems ok here in UK of GB & NI, Win7/Opera + the Android app both performing fine.

    The trouble is there are so many variables that can cause performance problems. If most of the rest of us are finding it OK though, the suspicion then tends to fall on either the complainant's equipment, or on their ISP connection, or any of a dozen or so router sites between the ISP and the forum server ... or the DNS servers that the ISP is using ... or one of the global master DNS servers ... or maybe someone's trawled up a deep-sea cable ... or maybe it's the CIA/NSA/GCHQ intercepting the packets in a bid for global domination by the NWO ...
     
  8. Briar

    Briar SC All-Pro

    Oct 27, 2010
    Scotland
    Karen
    I have occasional issues viewing threads with my iPad. Home/landing page no problem just when I try to open a thread. Not slow though, just doesn't go anywhere.
     
  9. krugorg

    krugorg SC All-Pro

    Sep 26, 2011
    Minnesota USA
    Kyle Krug
    I have had some very slow load times when opening threads (like Karen said home page usually loads quickly) over the past couple weeks. Not 100% sure, but I think it is only happening with my Macbook. Do not have the same issue with any of the sister sites (when I try them at the same time).
     
  10. Will

    Will SC All-Pro

    Aug 30, 2010
    England
    Not recently but a few weeks ago I gave up trying because the pages took so long to load. Sometimes refusing to altogether.

    Mac Book air
    OS X Lion 10.7.5

    Safari Version 6.0.5 (7536.30.1)
     
  11. bartjeej

    bartjeej SC Hall of Famer

    Nov 12, 2010
    bart
    No issues (Holland, Windows XP, browsers: IE8 and Google Chrome). Never had any trouble at the time of the previous round of reported slowness either.
     
  12. kyteflyer

    kyteflyer ~@¿@~

    Jan 31, 2011
    Newcastle, Australia
    Sue
    No issues, Australia, Mac Mini with 16GB RAM. HOWEVER at one point yesterday I did have problems with everything because a flash game I was playing ate all my memory and the Mac ran out. Rebooting solved.
     
  13. monk3y

    monk3y SC Regular

    153
    Aug 12, 2013
    Japan
    Steven
    Yes it is a tad slow from time to time. I am in Japan.

    Windows 8, Chrome browser.
     
  14. BBW

    BBW Administrator Emeritus

    Jul 7, 2010
    betwixt and between
    BB
    None for me here with a MacBook Pro and "on Safari" in the wilds of northwestern Connecticut.

    I know that a good pal across the pond was having problems a few days ago...not sure if he still is.
     
  15. Pim

    Pim SC Regular

    157
    Apr 21, 2012
    Eindhoven, The Netherlands
    Pim
    Did not notice any issues on my Windows 8 machine
     
  16. Ray Sachs

    Ray Sachs SC Legend

    Sep 21, 2010
    Not too far from Philly
    you should be able to figure it out...
    No problem here either - Google Chrome on a desktop and laptop Mac...

    -Ray
     
  17. ReD

    ReD SC Hall of Famer

    Mar 27, 2013
    No real problem with speed but today for some reason its not showing in my history (windows XP / internet explorer )
     
  18. Biro

    Biro SC All-Pro

    Aug 7, 2011
    Jersey Shore
    Steve
    Computer games are bad for you. :tongue:

    Meanwhile... I usually access the site on my iPad at home and Windows 7 PC at work. No issues with either lately although I have experienced slowness loading pages in the past.
     
  19. drd1135

    drd1135 SC Hall of Famer

    Jul 13, 2011
    Southwest Virginia
    Steve
    I had a problem a while back, but things have been fine lately.
     
  20. Boid

    Boid SC All-Pro

    Dec 15, 2011
    Bangalore, India
    Rajiv
    The front page loads quickly enough, but the subsequent click through to a forum post sometimes takes ages to load. It's very erratic, and sometimes I quit in frustration.

    MacPro + OS X 10.8.4 + Chrome

    I have ADBlock disabled for this site. DoNotTrackMe is kept running. Not sure is that has any effect on the performance of the site.