X100 Firmware 1.11 Update Posted

Discussion in 'Fuji X100 Forum' started by ntrolls, Oct 18, 2011.

  1. ntrolls

    ntrolls SC Regular

    43
    Oct 8, 2011
    London, UK
    • Like Like x 1
  2. Streetshooter

    Streetshooter Administrator Emeritus S.C. Charter Member

    Jul 12, 2010
    Philly, Pa
    I'd say it's a decent upgrade.
    The AF box staying consistent, the 16:9 frame and the ISO in the screen, very nice indeed.
     
    • Like Like x 1
  3. BBW

    BBW Administrator Emeritus S.C. Charter Member

    Jul 7, 2010
    betwixt and between
    Real Name:
    BB
    Excellent news - thanks so much ntrolls!

    Now I just have to remember how to do it.:wink:
     
  4. Streetshooter

    Streetshooter Administrator Emeritus S.C. Charter Member

    Jul 12, 2010
    Philly, Pa
    BB, you remember.... Call Don...
    We'll get it done
     
  5. BBW

    BBW Administrator Emeritus S.C. Charter Member

    Jul 7, 2010
    betwixt and between
    Real Name:
    BB
    :redface: That I do! I will have faith that this time, that I won't screw it up.

    On a different note, this warning makes me a bit nervous:

    Maybe I'll wait for Ray to update first?:tongue:
     
  6. christilou

    christilou SC Hall of Famer S.C. Charter Member

    Jul 13, 2010
    Sunny Frimley
    I've been too afraid to do the last one:rolleyes:
     
  7. BBW

    BBW Administrator Emeritus S.C. Charter Member

    Jul 7, 2010
    betwixt and between
    Real Name:
    BB
    No! You really should...and it looks as though this new one will be especially good for jpeg users. Heck, I may even try them again.

    Whoever goes first, please promise to report in, OK?
     
  8. BigTam

    BigTam SC Regular

    98
    Jun 23, 2011
    Dortmund, Germany
    Real Name:
    Ron
    Done. But the custom settings for the display information seem screwed. I have the Distance Scale and the Level Indicator set for both OVF and EVF/LCD, but they only appear on the EVF, not in the OVF. The LCD displays everything but not what the sensor sees!! The EVF does.
     
  9. Streetshooter

    Streetshooter Administrator Emeritus S.C. Charter Member

    Jul 12, 2010
    Philly, Pa
    When have you seen an update without a notice like that?
    Ya just have to pay attention and follow directions.
     
    • Like Like x 1
  10. BigTam

    BigTam SC Regular

    98
    Jun 23, 2011
    Dortmund, Germany
    Real Name:
    Ron
    Update: Started again from scratch, but the camera says I already have the update, so does nothing.

    Now the LCD does show the sensor picture, though, and the Level Indicator and Distance Scale, but the EVF does not!!

    Very mysterious ...
     
  11. Ray Sachs

    Ray Sachs SC Legend Subscribing Member

    Sep 21, 2010
    Not too far from Philly
    Real Name:
    you should be able to figure it out...
    Hmmm, only three changes (the vast majority of items listed on the update page were from the last upgrade to version 1.1 - the BIG one a few months ago). The only new fix I care about at ALL is improved AF at close distances, but I don't care about that all that much for the way I use this camera. I'll probably get around to it, but it doesn't feel like a priority. I'm just not aching to go through and write down all of the various settings I have cranked into the camera so I can make sure I get them right again after the update. Probably more important for me as a jpeg shooter with this camera than some others.

    But it should be very easy to do. I'd bypass all of the Mac and PC updating software and just do it through the camera. Just download the FPUPDATE.DAT file and then copy that file onto a blank, freshly formatted SD card. Make sure your battery is pretty fully charged so it doesn't crap out mid-update - THAT would be bad! Put the card in the camera. Turn on the camera while holding down the "disp/back" button. Then just follow the prompts that come up on the screen. Pretty simple process.

    -Ray
     
    • Like Like x 1
  12. Ray Sachs

    Ray Sachs SC Legend Subscribing Member

    Sep 21, 2010
    Not too far from Philly
    Real Name:
    you should be able to figure it out...
    Try toggling the display/back button while looking through the EVF. Now do the same with the OVF. I predict all of your options are still there!

    -Ray
     
  13. Streetshooter

    Streetshooter Administrator Emeritus S.C. Charter Member

    Jul 12, 2010
    Philly, Pa
    Tam, maybe turn off the camera, pull the battery, let it sit for a minute then put the battery back & start up.
    That could reset the memory.
    Don
     
  14. Ray Sachs

    Ray Sachs SC Legend Subscribing Member

    Sep 21, 2010
    Not too far from Philly
    Real Name:
    you should be able to figure it out...
    Well, OK, with all of this discussin' of it, I just went and did it. Nothing to it. Everything works fine. Theoretically its focussing a little better at close distance. I don't think I'll ever notice any difference in use. And all of my display options are still there in all three display modes - but I had to hit the disp//back button in each mode to get it how I like it.

    -Ray
     
  15. BBW

    BBW Administrator Emeritus S.C. Charter Member

    Jul 7, 2010
    betwixt and between
    Real Name:
    BB
    Thanks for your voice of experience, Don. I'm sure you're right.

    BigTam, I will await word from you after you've had more time for the update to cure.
     
  16. adanac

    adanac SC Veteran

    386
    Sep 30, 2011
    Vancouver, BC
    Why do you say that? I only see three issues resolved in this update (v1.11), none of them relating to JPEG output. Maybe I'm missing something...?
     
  17. BBW

    BBW Administrator Emeritus S.C. Charter Member

    Jul 7, 2010
    betwixt and between
    Real Name:
    BB
    Much appreciated, Ray. Good point about noting one's settings before doing the update.
     
  18. BBW

    BBW Administrator Emeritus S.C. Charter Member

    Jul 7, 2010
    betwixt and between
    Real Name:
    BB
    adanac, in my quick perusal I spotted some which I believe are more for jpegs but I bow to you. "Dynamic range" in #8 and #21 "Image quality captured by Velvia / ASTIA mode is improved on mainly shadow tone (dark area), when dynamic range is set to 200% or 400%". Perhaps I am wrong.

    I have to admit that I just set my ISO, and take pictures - usually with the camera in Aperture preferred and use RAW...so I haven't had any "issues" with the camera. Over the next day or so I will read through the updates more carefully and see what others have to say, too.
     
  19. adanac

    adanac SC Veteran

    386
    Sep 30, 2011
    Vancouver, BC
    Ah, ok, I see where the opportunity for confusion has snagged us. V1.11 pertains only to the first 3 elements in the update notice; V1.10 refers to the next and much larger list of updates.

    Again, unless I'm missing something here which is always possible until I've finished my coffee, if one was running V1.10 already (mine was), with V1.11 you'll now also have those additional fixes for close autofocus, viewfinder solarization when certain settings are chosen, and the self timer.

    I was hoping the next update would be more than a minor bug fix myself but didn't hold out much hope given the minor point release (1.10 -> 1.11).

    It'd be nice if Fujifilm signaled there are functionality improvements coming, such as allowing the use of the RAW button as a second Fn button, or moving (or duplicating) the AutoISO menu as a submenu of the ISO list.
     
    • Like Like x 1
  20. Ray Sachs

    Ray Sachs SC Legend Subscribing Member

    Sep 21, 2010
    Not too far from Philly
    Real Name:
    you should be able to figure it out...
    BB, only the first three little items on that huge page of updates are about version 1.11. All of the rest were the changes that came in version 1.10, which I know you already have in your camera. So this update is just those three little items at the top of the page. #8 and #21 are already in your camera from the previous upgrade.

    -Ray
     
    • Like Like x 1